OpenX Country Stats into the UI

Recently I finished a new module to add informations about country (where does my users come from) into the statistics. Althrough OpenX 2.8 has a plugin openXDeliveryLogCountry which collects the country statistics, the part to integrate this data into the UI is still missing.

The Impressions column gets a new details link
The Impressions column gets a new details link

My new country-stats module fills the missing gap. With a simple click to the impressions column you get the country details of the current row – this works within all levels of the statistics.

Country statistics in detail
Country statistics in detail

The modul is available for OpenX 2.8 and 2.6 – unfortunately it require still some patching of codebase.

To get the files and instructions for OpenX 2.8 please download here: stats_country_2.8.zip For OpenX 2.6 please contact me.

Changelog:
Oct/04.2010: fixed column sorting (you only need to update stats-country.php)
Oct/28.2009: fixed missing path in Admin_DA_patch.txt
Aug/24. 2009: improved column sorting.

12 Gedanken zu „OpenX Country Stats into the UI“

  1. Hello

    I have Install it’s on Openx 2.8.10 . but it’s not show in report section

    can you please give any idea

  2. Hello
    I have Already Install “ openxDeliveryLogCountry“ And All Instruction to install text file . Now Show When i Click Impressions column “ www/admin/stats.php?entity=country&clientid=4&agency_id=1&period_preset=yesterday&period_start=2013-04-17&period_end=2013-04-17″ Going New Page Here Show „There are currently no Report available“ Last 3 days I’m try To > Please Give Me Any India .. Oh I’m Using Openx v2.8.10

  3. Please take a look into the database, table „ox_data_bkt_country_m“ (Impressions) or „ox_data_bkt_country_c“ (Clicks). Are there any rows logged after a banner has been displayed or clicked?

  4. Hello
    I’m see this both rows there is no banners logged here . when i browsed it’s no logged show . now how to solve it . any idea please

  5. Maybe the deliveryHooks configuration in your openx .conf.php has not properly updated, have a look at openx /var folder, within there is a section [deliveryHooks], for impression-logging there should be a row „logImpression“ containing „deliveryLog:oxLogCountry:logImpressionCountry“, like:

    logImpression=[…]deliveryLog:oxLogCountry:logImpressionCountry[…]

  6. Have A look Here My Delivery Hooks Status . is it ok . I look again don’t show report here and logged row still same no data logged

    logImpression=“deliveryDataPrepare:oxDeliveryDataPrepare:dataCommon|deliveryDataPrepare:oxDeliveryGeo:dataGeo|deliveryLog:oxLogCountry:logImpressionCountry|deliveryLog:oxLogImpression:logImpression“

  7. Weird, if the „normal“ impressions“ get logged into database table „ox_data_bkt_m“, but not into the country table „ox_data_bkt_country_m“ there’s something wrong with the openxDeliveryLogCountry-Plugin. I suggest to „reinstall“ the plugin, i.e. either a „deinstall“ followed by „install“, or „import code only“ button. Maybe this helps.
    Before you may „switch“ accounts to Administration, goto Maintenanace -> Maintenanace -> Plugin and look at plugin report, if there is something wrong with any plugin.

  8. Hello I’m Check Plugins Report There is no error found . Also Diagnose the Plugins „No problems detected “ I’m Try to Re install the Plugins Same Condition No Report Show Database Table „ox_data_bkt_m“ are Show Logged But “ox_data_bkt_country_m“ Show not Logged . openXDeliveryLogCountry 1.0.2-dev it’s show Dev Version . Can Others Version have it’s . Please Give me An Another s Idea

  9. Hello bro . the problem are now solve . actually the problem is my delivery engine . the plugins are not active my delivery engine that’s why report are not logged in database . thank a lot for this patch

  10. Hello

    Suzon, what do you did? i have the same problem but in the database the info is logged in “ox_data_bkt_m” and “ox_data_bkt_country_m” but still give me “There are currently no Report available”. What do you mean by actually the problem is my delivery engine . the plugins are not active my delivery engine, what exactly you do?

Schreibe einen Kommentar